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Generating a color-editable SVG

This guide takes you through converting a 3D model into a 2D graphic and editing its code so that
its color can be changed within SmartSpace.

The guide covers the following steps:

e Exporting a file from SketchUp in PDF format

» Editing the PDF file in Illustrator

o Exporting the file from Illustrator in SVG format

e Editing the SVG's code to make it color adjustable

» Importing the image for use as a representation in SmartSpace

The examples show the conversion of a 3D drawing of an AC generator into a 2D SVG. The source
file for the example is provided in a zip file ColorEditableSVG.zip on the Ubisense Documentation

Portal at https://docs.ubisense.com/portal/Content/Downloads/Files/. If you want to work
through the instructions step by step, download and unzip the file to a suitable location.


https://docs.ubisense.com/portal/Content/Downloads/Files/ColorEditableSVG.zip

Software Required

The following lists the software required if you want to work through the example.

SketchUp® Pro

The example in this guide uses SketchUp Pro desktop software available from
https.//www.sketchup.com/.

Note: You cannot use the free web-based version of SketchUp to create a 2D graphic in SVG
format from a 3D SketchUp drawing.

Adobe® Illustrator® (trial version)

If you do not have a copy of Adobe® lllustrator®, you can download a free seven-day trial of the
software.

Go to https.//www.adobe.com/uk/products/illustrator/free-trial-download.html#x and follow the

instructions on the Adobe website.

Note: You will be required to supply payment details during the download process.

Notepad++

You will need access to a text editor to edit the SVG. The example in this guide uses Notepad++.
You can download the Notepad++ software from https.//notepad-plus-plus.org/download/ or use

your preferred text editor.


https://www.sketchup.com/
https://www.adobe.com/uk/products/illustrator/free-trial-download.html#x
https://notepad-plus-plus.org/download/

Exporting a file from SketchUp in SVG Format

Exporting a file from SketchUp in SVG Format

Opening the file in SketchUp

1. Open SketchUp by typing sketchup in the Start menu.The SketchUp startup window is
displayed.

2. Open a new SketchUp document by choosing File > New (Ctrl+0), going to the directory
where you unzipped the example files, and choosing AC Generator.skp:

This will open the document in SketchUp and the window will look like this:

WIS 0 0SS CH L EB| G zLH OSSR ®
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Editing the model for export

Next change the view in SketchUp so you are looking down on the object. Choose Camera >
Standard Views > Top.



Exporting a file from SketchUp in SVG Format

B AC Generator.skp - SketchUp Pra 2017
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This should now be the view:
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Exporting a file from SketchUp in SVG Format

Next change the viewing mode from “perspective” to “parallel projection”: Choose Camera >
Parallel Projection.
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Next remove the outlines of the model by choosing View > Edge Style and deselecting Edges and

Profiles.



Exporting a file from SketchUp in SVG Format

B AC Generator.skp - SketchUp Pro 2017
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Once deselected the ticks will disappear beside Edges and Profiles and the object should look like
this:



Exporting a file from SketchUp in SVG Format

B AC Generator.skp - SketchUp Pro 2017
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Saving the model as a PDF

With the model lined up, choose File > Export > 2D Graphic.



Exporting a file from SketchUp in SVG Format

B AC Generator.skp - SketchUp Pro 2017
File Edit View Camers Draw Tools Window ions  Help

Now C|.|+Ncm‘¢ﬂ‘@“¢@,.x|§“@|‘

Open... e

Save Ctrl+S
Save As..

Save A Copy As...

Save As Template...

Revert

Send to LayOut..

Geo-location >
3D Warehouse >
Trimble Connect >
Import..
3D Model...

Print Setup...

Print Preview... Section Slice.

Print... Ctriep Animation

Generate Report...

1 AC Generator.skp

23 system nitrogen mule.skp

3 Aircraft Engine Stand.skp

4 Mobile tool boxtrailer.skp

3 Aircraft Maintenance Platform - Ver2.skp
63D Man.skp

7QPE2019 venue.skp

8 Table and Bannerskp

Exit

Next the Export 2D Graphic dialog will appear: make sure the document is saved as the file type
“PDF".



Exporting a file from SketchUp in SVG Format
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Editing the PDF file in Adobe® lllustrator®

1. Open lllustrator by typing illustrator in the Start menu.The Illustrator startup window is

displayed.

2. Choose File > Open, navigate to the location where you saved the PDF file, and open the
file:

3. To simplify the vector file, select areas of similar color and use the Pathfinder tool to
connect the shapes.

Display the Pathfinder tools by choosing Window > Pathfinder or by pressing
Shift+Ctrl+F9.

10



Editing the PDF file in Adobe® lllustrator®

For example, click and drag the cursor over the wheels at the side until all the necessary
parts are selected. The selected shapes should look like this:

.,{

With the shapes selected, click the Unite (Pathfinder) icon to join the shapes:

Pathfindear

. I RN

The joined shape should now look like this:

4. Carry out this same process for any sections composed of multiple shapes of a similar color,
some example pictures of sections this can be performed on are as follows:

1"



Editing the PDF file in Adobe® lllustrator®

[

©

5. Finish by resizing the artboard so it tightly fits around the object.
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Editing the PDF file in Adobe® lllustrator®

a. Choose Windows > Artboards. If you are using the Essentials Classic workspace you
can choose the Artboards icon from the tools on the right-hand side of the
workspace:

Properties

No Selection

Document
Units:  Pixels e
Arthoard: 1 b

Edit Arthoards

FHBEA
I da 5
{2 I i

Keyboard Increment: 1 px

[] use Preview Bounds

b. Select Artboard 1in the Artboards panel and choose Object > Artboards > Fit to
Artwork Bounds.
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Exporting an SVG file from Illustrator

Exporting an SVG file from Illustrator

When the file has been cleaned it can be saved as a vector file (SVG).
With file editing complete in lllustrator, the final step is to save the result as a vector file (SVG).

1. Choose File > Save As... and in the dialog, ensure the file type is set to SVG (*.SVG) and
that Use Artboards is checked:
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2. Give the file a name.

3. Click Save and then click OK to save the default settings in the SVG Options dialog:

[ Include Unused Graphic Styles
Encoding: Unicode (UTF-8)  ~
9 Cutput fewer <tspan> elements (] Include Slicing Data

[ Use <textPath> element for Text on Path [ Include XMP
4 Responsive

Less Options

This will provide you with an SVG file which can be successfully imported into SmartSpace.

14



Adjusting the SVG's Code

Adjusting the SVG’s Code

Now that the SVG has been saved, the next step is to make it color editable. We only want to
make the main body editable and to do this we need to find out its color value.

1. Select the main body color in illustrator, then select the color selection tool on either the

left or right side of the workspace:

asS»ryv g

>

."
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Adjusting the SVG's Code

« If you select the left option, the following dialog will appear:

Color Picker

Select Color:

[C] only web Colors

« If you select the right option, the following window will appear (make sure the paint
palette icon is selected):

2. In either dialog, the color hex code can be found at the bottom. In this instance the code is:
#FFFFFF

Remember this code as it will be important later.

Now use Notepad++ (or your preferred text editor) to edit the code of the SVG.
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Adjusting the SVG's Code

1. To edit the code of the SVG, in File Explorer right click the filename and choose Edit with
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2. In the Notepad++ window you will see a list of all the color values (Fill Colors):
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Adjusting the SVG's Code

Fie fdt Serch View Encoding Langusge Setings Tools Macro Run Plgins Window 1
cHHERGRIsGh|ioc|an as|BB|1(F Ao BEN BB &
] EAC Generatorsva B |

1 <oxml version="1.0" encoding="atf-8"2>
¢

e Illustrator 23.0.3, SVG Export Plug-In . SVG Version Build 0) -->
3 ="http://wiw.w3.orq/2000/svq" xmlns:xlink="http://www.w3.orq/1999/x1ink" x="0px"
4 " xml:spac

LSE1(£111:#2A2A24;)
LSt2(£111:4272727;)
-SE3{F1L.
.stageill
-SES{FI1L.
-st6{£ill
LSET(£111,
-SEB{FILL.
| StO(Fil1:#A3A3A3 )

<style type="text/css">

20| Lo
.StO{fill:#111111;}
.St1{fill:#2A2A2A;} 14,4 632.3,4 641.2,4 652.4,4 662.2,4 674.6,4 684.5,4 696.9,4 705.7,4
.St2{£ill:#272727:} 30515176 109.2/1.6 468:5,1.6 450.6,1.6 436.1,1.6 426.8,1.6
25 .st3{fi11:#242424;} 559.3,4 561.3,4 554.9,1.6 ">
26 ||sg

<g> .st4{fill:#FF9800;}
I .st5{fill

0.5 730.3,460.5 727.3,460.8 726.2,460.5 726.1,460.5 717.3,460.8
#FFFFFF; } B 70,5, 480, 630.2,460.0 645,246, 430,460.5 630,460.6 621.1,460.8

2 LSt6{fill:#BTBCCO;} & rosatcos oo

33 .st7{£fi11:#F40000;} 460.8 435.8,460.8 432.9,460.8 429.4,460.8 423.7,460.8 420.8,460.8
35 | .st8{fill:#1F1F1F;} 463.2 554,460.8 552.1,460.8 />

36 <¥q|

£ LSEO{Fill:#A3ABAS; ] & earemo.s ser.e6a cer.a,e6.0 aer.4,c0.2 574,90,

38 | 7.4,111.7 887.4,114.1 887.4,115.6 887.4,116.1 887.4,122.3

=

L St10{F£il1:#ACACAC; } b oor.4,157.2 007.4,141 597.4,240.6 857.4,147.7 067 4,150.1
7 887.4,317.1 867.4,320.1 867.4,323.7 887.4,327.6 §7.4,331.5
.st11{fill:#1E1E1E;} 87.4,348.7 887.4,349.2 887.4,350.7 887.4,353.1 887.4,356.1
% 867.4,376.5 887.4,378 887.4,378.5 "/>

F</style> 16,4 743.1,4 738.4,4 737.4,4 732.8,4 727.3,4 726.1,4 724,4

TG T T U OO T oor Iz & 641.2,4 632.3,4 623.4,4 616.4,4 610.7,4 606.1,4 604.2,4 602.6,4

561.3,4 559.3,4 557.7,4 552,4 547.5,4 536.6,4 531.6,4 520.4,4 511.5,4 495.1,4 489.3 4 476.9,4 467,4 455.6,4 447,4 438.1,4

432.5,4 431, 425.3,4 420.5,4 420.5,4 419.6,4 418.5,4 417.3,4 405.5,4 395,4 389.9,4 354.5,4 383.1,4 383.1,73 384.5,73 369.9,73

399,73 408.5,73 415.6,73 420.8,73 432.9,73 714,73 726.1,73 727.3,73 738.4,73 748.9,73 757,73 762.1,73 763.8,73 763.8,4 "/>

<Polygon class="st3" pointe='762.1,391.8 757,391.5 748.9,391.5 738.4,391.5 727.3,391.8 726.1,391.8 714,391.5 432.9,391.5
420.8,391.5 419.6,391.5 408.5,391.5 398,391.5 389.5,391.5 384.5,391.5 383.1,391.8 383.1,460.5 384.5,460.5 389.9,460.5
398,460.8 406.5,460.6 416.3,460.6 417.7,460.8 419.6,460.8 415.7,460.8 420.8,460.8 423.7,460.6 429.4,460.8 432.9,460.6
43505,460.8 444.7,460.5 452.7,460.8 463.9,460.6 472.6,460.6 485.2,460.5 494,460.8 506.4,460.6 514.5,460.6 525.6,460.8
532,460.5 540.9,460.8 544.9,460.8 550.6,460.8 552.1,460.8 554,460.8 601.6,460.8 603,460.8 605,460.5 609.1,460.8 614.8,460.8
62111,460.8 630,460.6 638,460.8 649.2,460.8 656.1,460.8 670.5,460.8 679.4,460.6 691.6,460.6 699.8,460.8 711,460.8 714,460.8
717.3,460.5 726.1,460.5 726.2,460.8 727.3,460.5 730.3,460.5 736,460.5 737.4,460.8 735.4,460.5 739.4,460.5 745.9,460.5
757,460.8 762.1,460.8 763.8,460.6 763.8,391.8 "/>

<path class='sti" d="MI58.9,249.1v-33.4v-28.6L66,232.4167.3,32.6v4.510,01-1.2,0.51-1,0.51-0.8,11-0.5,1.21-0.2,1.310.2,1.3
10.5,1.210.8,111,0.811.2,0.511.3,0.211,3-0.211.2-0.511-0.510.8-110.5-1.210.2-1.31-0.2-1,31-0.5-1.21-0.5-11-1-0.81-1.2-0.510-3.3
123.1,11.3v-27.1V249. 12 M43.3,221.31228,131.2v22.21-50,24. 4V287150, 24. 4v22 . 2L43..3,243. 506 3v-22 . 2H43. 32" />

<Polygon class="stl" pointe='49.6,221.3 49.6,243.5 43.3,243.5 36.9,243.5 36.9,241.9 36.9,222.9 36.9,221.3 43.3,221.3 "/>

<g>

<polygon class="st2" po 887.4,86.3 887.4,86.8 887.4,88.3 887.4,90.6 887.4,93.7 887.4,97.3 887.4,101.2 887.4,105

eXtensible Markup Language file length: 14,305 fines : 154 Ln:1 Col:39 Sel:0]0 Windows (CRLF)  UTF-8

The color you need to adjust is the one whose value was identified previously: #FFFFFF.

3. Make the color adjustable by changing (fill:#FFFFFF;) to (stroke:none;).
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Adjusting the SVG's Code

Qj" *D\Smartspace Models\MRO Aero Event FactonAdditic
File Edit Search View Encoding Language Settin
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on="1.0" enc ng="ut

STTra

or: Adobe Illustrato

<svyg ve n="1.1" id="Layer 1"
g E vie *x="0 0 890.1 464.59" =
£ —<ztyle type="text/oss">

E .stO{fill:#111111;}
7 .st1{fill:#2A2A2A;}
: .st2{fill:#272727;}
.st3{fill:#242424;}

!

.stﬁfstroke:none:j

13 .st7{fill:#F40000;}
14 .stB{fill:#1F1F1F;}
15 .st9{fill:#A3A3A3;}
16 .st10{fill:#4C4C4C;}
17 .st11{fill:#1E1E1E;}
18 Fofatyles

C r—-l £

Now if the SVG is opened it should look something like this
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Importing the image into SmartSpace

This section describes how you can import your color-editable 2D image into SmartSpace using
the SmartSpace Config application. If you need further information on using SmartSpace Config,
see Configure SmartSpace on the Ubisense Documentation Portal.

1. Run SmartSpace Config and open the MODEL IMPORT tab:

2. Double-click <Import representation>.
3. Navigate to the SVG file which you exported from Illustrator and select it.

The filename, including its suffix, becomes the default name of the representation. Edit the

name as required.
4. Click Save.

The Model import workspace should look like this:
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Importing the image into SmartSpace
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If necessary, you can resize and set the origin of the model. See Model import for further
information on importing representations into SmartSpace.

You can now associate the model with a type, and assign instances of the type different colors
either manually or using the Business rules engine.
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